Skip To Content

00151 - Tool <value> is unsupported on server

The result references a tool or function that is not supported for use in ArcGIS Server. Tools and functions not supported in the ArcGIS Server environment include

  • All tools inside the Metadata toolset (Conversion toolbox)
  • All tools inside the Coverage toolbox
  • All tools inside the Mobile toolbox
  • All tools inside the Graph toolset (Data Management toolbox)
  • arcpy.mapping.ExportReport function
  • arcpy.mapping.PrintMap function
  • arcpy.mapping.ListPrinterNames function
  • arcpy.mapping.DataDrivenPages.PrintPages function
  • Skyline Graph tool (when optional output graph parameter is used)
  • Stack Profile tool (when optional output graph parameter is used)
  • Zonal Histogram tool (when optional output graph parameter is used)
  • Custom geoprocessing tools (in particular Python toolbox tools) may include an underscore in their tool name. To run correctly on ArcGIS Server, the underscore must be removed.

Solution

You must replace the tool with one that is supported.


In this topic
  1. Solution