Skip To Content

ArcGIS Enterprise Builder 10.6 system requirements

ArcGIS Enterprise, the next evolution of the ArcGIS Server product line, has a flexible deployment model allowing for use completely on-premises, in the cloud, or a combination of the two. The ArcGIS Enterprise Builder product includes the following software components that are designed to work together:

  • ArcGIS Server
  • Portal for ArcGIS
  • ArcGIS Data Store
  • ArcGIS Web Adaptor

ArcGIS Image Server, ArcGIS GeoEvent Server, ArcGIS GeoAnalytics Server, and Esri Business Analyst Server are specialized licensing roles for ArcGIS Server. See What is ArcGIS Enterprise in the ArcGIS Server help for more information.

The system and hardware requirements required to run ArcGIS Enterprise Builder are listed below. A diagnostics tool runs during the setup to help you determine if your machine meets the minimum system requirements. For information about earlier versions, see Esri Support. If your Portal for ArcGIS organization will use a premium app, such as ArcGIS Pro or Drone2Map for ArcGIS, you will also need ArcGIS License Manager 10.6 to configure your premium app licenses to specify which members can use the software. See the Portal for ArcGIS Administrator Guide, License Manager Reference Guide, and the License Manager system requirements for more information.

It's recommended that you review the deprecation notice to determine if your hardware and software components are still compatible with version 10.6, and to review all current system requirements of the individual products at ArcGIS Enterprise Installation Guides documentation.

Operating system requirements

The following 64-bit operating systems satisfy the minimum operating system requirements. Support is not provided for 32-bit operating systems; the setup will only proceed if the operating system is 64 bit. ArcGIS Enterprise is only supported on Linux x86_64, on CPUs that adhere to the x86_64 architecture (64 bit), with supported Linux releases.

Machines with an underscore (_) in the name are not supported. The setup will not proceed if an underscore is detected in the machine name.

The software should not be installed on an OS (binary) that has been modified. Esri does not provide support for products installed on a developer's release of an operating system.

You cannot install the software as a root user. If you attempt to do this, the installation will not proceed, and a software diagnostics tool will display an error message indicating that you cannot install as root.

Note:
A Java Application Server and the Java Linux Web Adaptor needs to be installed prior to Enterprise Builder in order to complete the setup and configuration.

Supported operating systemsLatest update or service pack tested

Red Hat Enterprise Linux Server 7

Update 4

Red Hat Enterprise Linux Server 6

Update 9

SUSE Linux Enterprise Server 12

Service Pack 2

SUSE Linux Enterprise Server 11

Service Pack 4

Ubuntu Server LTS

16.04.3

CentOS Linux 7

7.4

CentOS Linux 6

6.9

Scientific Linux 7

7.4

Scientific Linux 6

6.9

Oracle Linux 7

Update 4

Oracle Linux 6

Update 9

Prior and future updates or service packs on these operating systems are supported unless otherwise stated. The operating system version and updates must also be supported by the operating system provider.

Note:

Esri Technical Support is available for CentOS, Scientific Linux, and Oracle Linux versions that provide full binary compatibility with an equivalent supported Red Hat version. As a prerequisite for logging a defect, any software issue on these operating systems will be attempted to be reproduced on Red Hat Enterprise Linux. For Oracle Linux, support is predicated on the use of the Red Hat compatible kernel.

Tip:

If you want to install the software, run the ArcGIS Software Authorization Wizard, or run the Check for Updates tool using the operating system graphical user interface (GUI), the X Window System package group is required.

Hardware requirements

Disk space requirements

ArcGIS Enterprise Builder requires a minimum of 20 GB of available disk space, in which 5 GB of this total space must be available on the system drive.

Memory Requirements

It is strongly recommended to have at least 16GB of memory to install ArcGIS Enterprise Builder.