Skip To Content

ArcGIS Enterprise SDK 10.6.1 system requirements

The system and hardware requirements to run ArcGIS Enterprise SDK are listed below.

It is recommended that you review the deprecation notice to determine if your hardware and software components are still compatible with version 10.6.1.

Operating system requirements

The following 64-bit operating systems satisfy the minimum operating system requirements. Support is not provided for 32-bit operating systems; the setup will only proceed if the operating system is 64-bit.

Supported operating systems Latest update or service pack tested

Windows Server 2016 Standard and Datacenter

Version 1607 with May 8, 2018 update

Windows Server 2012 R2 Standard and Datacenter

May 8, 2018

Windows Server 2012 Standard and Datacenter

May 8, 2018

Windows Server 2008 R2 Standard, Enterprise, and Datacenter

SP1 with May 8, 2018 update

Prior and future updates or service packs on these operating systems are supported unless otherwise stated. The operating system version and updates must also be supported by the operating system provider.

Note:

Windows 10, Windows 8.1, and Windows 7 SP1 are supported for basic testing and application development use only. They are not recommended for deployment in a production environment.

Supported operating systems Latest update or service pack tested

Windows 10 Pro and Enterprise

Version 1803 with May 8, 2018 update

Windows 8.1 Pro and Enterprise

May 8, 2018

Windows 7 Ultimate, Professional, Enterprise, and Home Premium

SP1 with May 8, 2018 update

Operating system requirements and limitations

Windows

Disk space requirements

Enterprise SDK with all features for .NET on Windows requires approximately 550 MB of disk space.

Enterprise SDK with all features for JAVA requires approximately 250 MB of disk space.

Developer solutions (SDK) requirements

Development platformSupported and Recommended IDE's SDK Requirement

.NET

Visual Studio templates (which contains boilerplate code) are provided with Enterprise SDK for the .NET Platform and are supported in the IDEs listed below.

  • Microsoft Visual Studio 2017 (C#, VB.NET) Community, Professional, Enterprise
  • Microsoft Visual Studio 2015 (C#, VB.NET) Community, Professional, Premium, Ultimate Edition

ArcGIS Server is required when deploying an SOE and ArcGIS Pro is required when publishing map services. However, ArcGIS Server and ArcGIS Pro do not need to be installed on the same machine where the ArcGIS Enterprise SDK is installed; they can be on remote machines.

Microsoft .NET Framework 4.5 or higher

Java

Eclipse IDE plug-ins, which offer an enhanced developer experience through templates, and project wizards, are provided with Enterprise SDK for the Java Platform and are supported in the IDEs listed below.

  • Eclipse Oxygen (4.7) IDE for Java Developers
  • Eclipse Oxygen (4.7) IDE for Java EE Developers
  • Eclipse Neon (4.6) IDE for Java Developers
  • Eclipse Neon (4.6) IDE for Java EE Developers

ArcGIS Server is required when deploying an SOE and ArcGIS Pro is required when publishing map services. However, ArcGIS Server and ArcGIS Pro do not need to be installed on the same machine where the ArcGIS Enterprise SDK is installed; they can be on remote machines.

Java Development Kit (JDK) version 8 Update 144 or later is supported.

Operating system requirements and limitations

Windows