Skip To Content

Portal-Kompatibilität mit früheren Versionen von ArcGIS

Dieses Thema enthält Antworten auf häufige Fragen zur Kompatibilität von Portal for ArcGIS mit früheren Versionen von ArcGIS.

Ich möchte meine ArcGIS Server-Site mit Portal for ArcGIS verbinden. Müssen beide Produkte in derselben Version ausgeführt werden?

Das hängt von der Rolle des Servers im System ab. Jeder ArcGIS Server, der als Hosting-Server definiert bzw. als GeoEvent Server, als GeoAnalytics Server oder als Raster-Analyse-Server lizenziert ist, muss mit der Version des Portals übereinstimmen, mit dem er verbunden ist. Ein Portal der Version 10.5.1 oder höher kann mit jedem Server-Typ der Version 10.5 oder höher verbunden werden, auch wenn die Versionen nicht übereinstimmen.

Kann ich eine frühere Version von ArcGIS Web Adaptor in Portal for ArcGIS konfigurieren?

Nein. Um ArcGIS Web Adaptor mit Portal for ArcGIS zu konfigurieren, müssen beide Produkte in derselben Version ausgeführt werden.

Kann ich ArcGIS 10.8 Web Adaptor (IIS) auf demselben Computer wie eine frühere Version von ArcGIS Web Adaptor (IIS) installieren?

Ja. Ab Version 10.2.1 kann Version 10.2.1 bzw. eine höhere Version von Web Adaptor zusammen mit einer anderen früheren Version von ArcGIS Web Adaptor (IIS) auf dem gleichen Computer installiert sein. Beispielsweise können die Versionen 10.1 SP1 und 10.8 von Web Adaptor auf dem gleichen Server installiert sein.

So wie in früheren Versionen muss die Version von Web Adaptor stets mit der Version von Portal for ArcGIS übereinstimmen. Beispielsweise können Sie die Version 10.8 von Web Adaptor nicht mit einer früheren Version von Portal for ArcGIS konfigurieren.

Um eine frühere Version von ArcGIS Web Adaptor (IIS) auf 10.8 zu aktualisieren, müssen Sie die frühere Version deinstallieren und das 10.8-Setup installieren. Nachdem Sie 10.8 installiert haben, müssen Sie Web Adaptor mit Portal for ArcGIS konfigurieren.

Weitere Informationen finden Sie unter Installieren von ArcGIS Web Adaptor (IIS).

Ältere Versionen:

In Versionen vor 10.2.1 mussten alle Web Adaptor auf einem Webserver dieselbe Versionsnummer verwenden. Durch Ausführung des Setup-Programms wurden alle vorhandenen Web Adaptor auf die aktuelle Version aktualisiert.

Kann ich in ArcGIS Desktop ausgeführte Elemente mit einer früheren Version von Portal for ArcGIS 10.8 veröffentlichen?

Ja. Sie können frühere Versionen von ArcGIS Desktop verwenden, um Elemente, die in Portal for ArcGIS 10.8 ausgeführt werden, zu veröffentlichen oder zu verwalten, vorausgesetzt Sie verwenden ArcGIS Desktop 10.2 oder höher.

Umgekehrt können Sie eine Version 10.1 SP1 oder früher von ArcGIS Desktop nicht zur Veröffentlichung oder Verwaltung von in Portal for ArcGIS 10.8 ausgeführten Elementen verwenden.

Kann ich mit einer früheren Version von ArcGIS Desktop in Portal for ArcGIS 10.8 ausgeführte Services anzeigen und verwenden?

Ja. In den meisten Fällen können Sie 10.8-Services zu früheren Versionen von ArcGIS Desktop hinzufügen. Die grundlegende Struktur und das Format von Webservice-Anforderungen in Services wurden in Version 10.8 nicht geändert. Wenn Sie jedoch eine Verbindung von einer niedrigeren Version als 10.2 von ArcGIS Desktop herstellen, müssen Sie eine Verbindung zu Portal for ArcGIS und nicht zur verbundenen ArcGIS 10.8-Server-Site herstellen, um die Services anzuzeigen.

Beachten Sie, dass Sie von früheren Versionen von ArcGIS Desktop nur mithilfe von Verbindungsoptionen, die in der verwendeten Portal for ArcGIS-Version unterstützt werden, eine Verbindung mit 10.8 ArcGIS Desktop herstellen können. Beispielsweise können Sie keine Anmeldedaten der integrierten Windows-Authentifizierung verwenden, um von ArcGIS 10.1 Desktop eine Verbindung mit Portal for ArcGIS 10.8 herzustellen, da Anmeldedaten der integrierten Windows-Authentifizierung in ArcGIS 10.1 Desktop nicht unterstützt wurden.

Wie lautet der Migrationspfad von früheren Versionen von Portal for ArcGIS zu Version 10.8?

Bei der Installation von 10.8 wird für Ihre vorhandene Portal for ArcGIS-Bereitstellung automatisch ein Upgrade auf 10.8 durchgeführ. Bei dem Upgrade wird jegliches benutzerdefiniertes Verhalten, das Sie für das Portal konfiguriert haben, z. B. Eigenschaften, die Sie in config.js geändert haben, nicht mit übernommen. Sie sind dafür verantwortlich, in einzelnen Versionen vorgenommene Anpassungen zu sichern und wiederherzustellen. Weitere Informationen zum Upgrade einer früheren Version von Portal for ArcGIS auf 10.8 finden Sie unter Upgrade von Portal for ArcGIS.

Die Migration zu Portal for ArcGIS 10.8 von einer niedrigeren Version als 10.2 ist nur durch Esri Professional Services möglich.