Skip To Content

ArcObjects SDK 10.9.1 system requirements

Visit Esri Technical Support for information on the Esri Supported Environment Policy.

Tip:

For earlier ArcGIS versions, see the system requirements on the ArcGIS Desktop website.

Supported Microsoft Windows platforms*

Supported operating systems Latest update or service pack testedArcObjects SDK for Java WindowsArcObjects SDK for the Microsoft .NET Framework**

Windows 11 Pro and Enterprise (64 bit [EM64T])

November 2021 update

Supported

Supported

Windows 10 Home, Pro and Enterprise (64 bit [EM64T])

September 2021 update

Supported

Supported

Windows 8.1 Basic, Pro, and Enterprise (32 bit and 64 bit [EM64T])

September 2021 update

Supported

Supported

Windows Server 2022 Standard and Datacenter

Supported

Supported

Windows Server 2019 Standard and Datacenter

September 2021 update

Supported

Supported

Windows Server 2016 Standard and Datacenter

September 2021 update

Supported

Supported

Windows Server 2012 R2 Standard and Datacenter

September 2021 update

Supported

Supported

Windows Server 2012 Standard and Datacenter

September 2021 update

Supported

Supported

Note:
Prior and future updates or service packs on these operating system versions are supported unless otherwise stated. The operating system version and updates must also be supported by the operating system provider.

*See Operating system requirements and limitations for additional requirements and information.

**The Microsoft .NET Framework requires Visual Studio 2017 or Visual Studio 2019. Refer to the following links for Microsoft Visual Studio system requirements:

Hardware requirements

See the following tables for hardware requirements:

Disk space requirements

ArcObjects SDKDisk space

ArcObjects SDK for Java Windows

676 MB

ArcObjects SDK for the Microsoft .NET Framework

676 MB

Developer Solutions (SDK) requirements

ArcObjects SDKSupported and recommended IDESDK requirements

ArcObjects SDK for Java Windows

Developer IDE plug-ins, which offer an enhanced developer experience through templates, code snippets, and project wizards, are provided with ArcObjects SDK for Java Windows and are supported in the IDE listed below. (Note: Visual beans users must manually install Visual Editor.)

  • Eclipse IDE for Java Developers (version 2020-12 or later)
  • Eclipse IDE for Java EE Developers (version 2020-12 or later)

ArcGIS Server is required to develop with ArcObjects SDK for Java Windows .

Java Development Kit (JDK) version 8 Update 302 or later versions of JDK 8 is supported when building SOE and SOI. Building SOE or SOI with Java 9 or higher is not supported.

ArcObjects SDK for the Microsoft .NET Framework

Microsoft Visual Studio 2019 (C#, VB.NET) Community, Professional, Enterprise

Microsoft Visual Studio 2017 (C#, VB.NET) Community, Professional, Enterprise

Microsoft .NET Framework 4.5.2 or later