Skip To Content

Requisitos de ArcGIS 10.9.1 y ArcGIS Pro 2.9 para Microsoft SQL Server

ArcGIS admite conexiones a bases de datos de Microsoft SQL Server y geodatabases corporativas de SQL Server.

Sugerencia:

Para las versiones de ArcGIS anteriores a 10.9 y ArcGIS Pro 2.8, consulte los requisitos del sistema en el sitio web de ArcGIS Desktop.

Visite Soporte técnico de Esri para obtener información sobre la Política de entorno compatible de Esri.

Versiones de base de datos compatibles

Las siguientes versiones de Microsoft SQL Server son las versiones certificadas mínimas que admite ArcGIS. Los Service Packs de SQL Server y actualizaciones acumulativas de estas versiones se admiten, pero no están certificados.

Ediciones Standard/Enterprise/Developer*

Microsoft SQL Server 2019 (64 bits)

Microsoft SQL Server 2019 en Linux (64 bits)

Microsoft SQL Server 2017 (64 bits)

Microsoft SQL Server 2017 en Linux (64 bits)

Microsoft SQL Server 2016 (64 bits)

Ediciones Express

Microsoft SQL Server 2019 (64 bits)

Microsoft SQL Server 2017 (64 bits)

Microsoft SQL Server 2016 (64 bits)

Nota:

*La edición Developer solo se admite en entornos que no sean de producción.

Sistemas operativos compatibles

Si su sistema de administración de bases de datos está instalado en un servidor en el que también están instalados productos de ArcGIS, el sistema operativo del servidor debe cumplir los requisitos del sistema del producto de ArcGIS, así como los requisitos del sistema operativo para su versión de SQL Server.

Si su base de datos no está instalada en el mismo servidor que un producto de ArcGIS, consulte la documentación de Microsoft para obtener los requisitos de sistema operativo correspondientes a su versión de SQL Server.

Compatibilidad con la nube

Consulte Requisitos para utilizar ArcGIS con bases de datos en la nube para obtener más información sobre la compatibilidad de los servicios de base de datos y bases de datos implementadas en la nube.

Software necesario para conectarse a SQL Server

Los equipos cliente que se conecten directamente con SQL Server deben tener instalado un cliente de SQL Server. Los clientes de SQL Server para Microsoft Windows y Linux los distribuye Microsoft. Los clientes de SQL Server para Windows también están disponibles en My Esri. Debe instalar un cliente de la misma versión o de una versión más reciente que la de la base de datos de SQL Server a la que desea conectarse. Si actualiza SQL Server, actualice al mismo tiempo los clientes de SQL Server. Cuando ArcGIS ya no admita una versión de SQL Server, tampoco se admitirá la biblioteca cliente de SQL Server correspondiente.

Los clientes de SQL Server compatibles son los siguientes:

  • SQL Server 2019
    • Microsoft ODBC Driver 17 para SQL Server
  • SQL Server 2017
    • Microsoft ODBC Driver 17 para SQL Server
  • SQL Server 2016
    • Microsoft ODBC Driver 17 para SQL Server
    • Microsoft ODBC Driver 13 o 13.1 para SQL Server