Skip To Content

Requisitos del sistema para ArcGIS Enterprise SDK 10.8.x

A continuación, se indican los requisitos de sistema y de hardware para ejecutar ArcGIS Enterprise SDK.

Se recomienda consultar el aviso de obsolescencia para determinar si sus componentes de hardware y software siguen siendo compatibles con la versión 10.8 y 10.8.1.

Requisitos de sistema operativo

Los siguientes sistemas operativos de 64 bits satisfacen los requisitos de sistema operativo mínimos. No se ofrece compatibilidad con los sistemas operativos de 32 bits; la instalación solo continuará si el sistema operativo es de 64 bits.

Sistema operativo compatibleÚltima actualización o Service Pack probado

Windows Server 2019 Standard y Datacenter

Actualizaciones de junio de 2020

Windows Server 2016 Standard y Datacenter

Actualizaciones de junio de 2020

Windows Server 2012 R2 Standard y Datacenter

Actualizaciones de junio de 2020

Windows Server 2012 Standard y Datacenter

Actualizaciones de junio de 2020

Las anteriores y futuras actualizaciones o Service Packs de estas versiones de sistema operativo serán compatibles y deberían funcionar, salvo que se indique lo contrario. El proveedor del sistema operativo deberá admitir también la versión y las actualizaciones del sistema operativo.

Nota:

La opción Experiencia de escritorio es necesaria en todas las versiones de Windows Server.

Sistema operativo compatibleÚltima actualización o Service Pack probado

Windows 10 Pro y Enterprise (64 bits [EM64T])

Actualizaciones de junio de 2020

Windows 8.1 Pro y Enterprise (64 bits [EM64T])

Actualizaciones de junio de 2020

Requisitos de espacio en disco

Enterprise SDK con todas las características para .NET en Microsoft Windows requiere aproximadamente 550 MB de espacio en disco.

Enterprise SDK con todas las características para Java requiere aproximadamente 250 MB de espacio en disco.

Requisitos de las soluciones de desarrollador (SDK)

Plataforma de desarrolloIDE compatibles y recomendadosRequisitos de SDK

.NET

Con Visual Studio SDK for the .NET Platform se proporcionan plantillas de Enterprise (que contienen código reutilizable), admitidas en los IDE que aparecen a continuación.

  • Microsoft Visual Studio 2019 (C#, VB.NET) Community, Professional, Enterprise
  • Microsoft Visual Studio 2017 (C#, VB.NET) Community, Professional, Enterprise

ArcGIS Server se requiere al implementar una SOE y ArcGIS Pro al publicar servicios de mapas. Sin embargo, no es necesario que ArcGIS Server y ArcGIS Pro estén instalados en el mismo equipo en el que está instalado ArcGIS Enterprise SDK; pueden estar en equipos remotos.

Microsoft .NET Framework 4.5.2 o posteriores

Java

En ArcGIS 10.8.1, ArcGIS Enterprise SDK utiliza el marco Maven para creación y administración de proyectos Java. Se pueden utilizar la mayoría de IDE de Java que son compatibles con el marco Maven y JDK 11, como, por ejemplo, IntelliJ IDEA, Eclipse IDE o NetBeans. Los IDE documentados y recomendados son los siguientes:

  • IntelliJ IDEA Ultimate (versión 2019.3.4 o posterior)
  • IntelliJ IDEA Community (versión 2019.3.4 o posterior)
  • Eclipse IDE para desarrolladores de Java (versión 2019-12 o posterior)
  • Eclipse IDE para desarrolladores de Java EE (versión 2019-12 o posterior)

En ArcGIS 10.8, se proporciona el plug-in de Eclipse con ArcGIS Enterprise SDK para la plataforma Java. El plug-in de Eclipse ofrece una experiencia de desarrollo mejorada a través de plantillas, asistentes de proyecto y muestras incorporadas. Se admite en los IDE siguientes:

  • IDE de Eclipse Photon (4.8) para desarrolladores de Java
  • IDE de Eclipse Photon (4.8) para desarrolladores de Java EE
  • IDE de Eclipse Oxygen (4.7) para desarrolladores de Java
  • de Eclipse Oxygen (4.7) para desarrolladores de Java EE

ArcGIS Server es necesario para implementar un SOE o SOI y ArcGIS Pro es necesario para publicar servicios. Sin embargo, no es necesario que ArcGIS Server y ArcGIS Pro estén instalados en el mismo equipo en el que está instalado ArcGIS Enterprise SDK; pueden estar en equipos remotos.

En ArcGIS 10.8.1, se admite Java Development Kit (JDK) versión 11.0.6 o versiones posteriores de JDK 11 al crear SOE y SOI. No se admite la creación de SOE ni SOI con Java 12 o posterior. Se admite Maven 3.6.1 o posterior.

En ArcGIS 10.8, se admiten Java Development Kit (JDK) versión 8, actualización 191, o versiones posteriores de JDK 8 al crear SOE y SOI. No se admite la creación de SOE ni SOI con Java 9 o posterior.