Skip To Content

Requisitos del sistema de ArcGIS Server 10.9

A continuación, se indican los requisitos de sistema y de hardware para ejecutar ArcGIS Server.

Se recomienda consultar el aviso de obsolescencia para determinar si sus componentes de hardware y software siguen siendo compatibles con la versión actual de ArcGIS.

ArcGIS Notebook Server presenta requisitos adicionales. Consulte Requisitos del sistema para ArcGIS Notebook Server.

Nota:

Los componentes de ArcGIS Enterprise requieren la versión mínima 14.22.27821 de Microsoft Visual C++ 2015–2019 Redistributable (x64). Obtenga el archivo Microsoft Visual C++ Redistributable para Visual Studio 2015–2019 en el sitio de Microsoft.

Si los Visual C++ Redistributables requeridos no están instalados, al ejecutar el archivo setup.exe de ArcGIS Server, se instalarán. Al ejecutar el archivo setup.msi de ArcGIS Server, no se instalarán. Por tanto, para ejecutar el archivo setup.msi de ArcGIS Server, debe instalar primero los Microsoft Visual C++ 2015 - 2019 Redistributables.

Requisitos del sistema operativo de Microsoft Windows

Los siguientes sistemas operativos de 64 bits satisfacen los requisitos de sistema operativo mínimos. No se ofrece compatibilidad con los sistemas operativos de 32 bits; la instalación solo continúa si el sistema operativo es de 64 bits.

Sistema operativo compatibleÚltima actualización o Service Pack probado

Windows Server 2019 Standard y Datacenter

Actualización de febrero de 2021

Windows Server 2016 Standard y Datacenter

Actualización de febrero de 2021

Windows Server 2012 R2 Standard y Datacenter

Actualización de febrero de 2021

Windows Server 2012 Standard y Datacenter

Actualización de febrero de 2021

Sistema operativo compatibleÚltima actualización o Service Pack probado

Windows 10 Pro y Enterprise (64 bits [EM64T])

Actualización de febrero de 2021

Windows 8.1 Pro y Enterprise (64 bits [EM64T])

Actualización de febrero de 2021

Nota:

  • Las anteriores y futuras actualizaciones o Service Packs para estas versiones de sistema operativo serán compatibles y deberían funcionar, salvo que se indique lo contrario. El proveedor del sistema operativo deberá admitir también la versión y las actualizaciones del sistema operativo.
  • La opción Experiencia de escritorio es necesaria en todas las versiones de Windows Server.
  • Windows 10 y 8.1 solo se admiten para el desarrollo de aplicaciones y pruebas básicas. No se recomiendan para la implementación en un entorno de producción.
  • Los equipos con un guión bajo (_) en sus nombres no son compatibles. Hay varias especificaciones de nombres de hosts de Internet muy utilizadas que designan el guion bajo como no estándar. Aunque Microsoft Windows admite el signo de guion bajo en un nombre de equipo, puede producir problemas al interactuar con otros servidores y plataformas. Por este motivo, la instalación no se realizará en servidores que tengan un guion bajo en el nombre de host.
  • No puede instalar en controladores de dominio. Instalar en un controlador de dominio puede tener un impacto negativo en la funcionalidad.

Requisitos de hardware

El requisito mínimo de memoria RAM para ArcGIS GIS Server, ArcGIS GeoEvent Server o ArcGIS Image Server es de 8 GB por equipo.

Para un entorno de producción, los requisitos de hardware no se enumeran porque las necesidades empresariales y del usuario del software pueden variar. Estos requisitos se deben tener en cuenta a la hora de determinar las necesidades de hardware para satisfacer las expectativas de escalabilidad y de rendimiento.

ArcGIS GeoAnalytics Server requiere un mínimo de 16 GB de RAM por equipo.

Cuando configure ArcGIS GeoAnalytics Server, asegúrese de que la unidad donde está alojado el perfil de usuario tenga suficiente espacio temporal o modifique la ubicación de archivos temporales de GeoAnalytics Server después de la instalación. Cuando calcule un valor de espacio suficiente, tenga en cuenta el tamaño de los datos de entrada, el tipo de tarea de GeoAnalytics y el número de nodos de su sitio.

Consulte Prácticas recomendadas para sitios de GeoAnalytics Server para obtener más información sobre la implementación de ArcGIS GeoAnalytics Server.

ArcGIS Server requiere un mínimo de 10 GB de espacio en disco disponible.

Configuración del cortafuegos

ArcGIS Server se comunica a través de puertos específicos. Debe abrir estos puertos en su firewall antes de instalar el software. Para obtener más información sobre los puertos que requiere ArcGIS Server para la comunicación, consulte Puertos utilizados por ArcGIS Server.

Recomendaciones de sistema de nombres de dominio (DNS) y nombre de dominio totalmente calificado (FQDN)

Si va a federar su sitio con un portal de ArcGIS Enterprise, se recomienda que configure el sistema de nombres de dominio (DNS) de su organización para que incluya entradas de nombre de dominio totalmente calificado (FQDN) para cada sitio que tenga previsto federar con el portal. Portal for ArcGIS solicitará el FQDN de cada sitio cuando lo federe.

Certificados SSL

ArcGIS Server se suministra configurado con un certificado autofirmado que le permite probar el sitio de ArcGIS Server inicialmente y le ayuda a verificar de forma rápida si la instalación se realizó correctamente. Debe solicitar un certificado a una entidad de certificación (CA) de confianza y configurar el sitio de ArcGIS Server para que lo use. Este puede ser un certificado de dominio emitido por su organización o un certificado firmado por una autoridad certificadora.

Como ArcGIS Server, Portal for ArcGIS también se suministra con un certificado autofirmado configurado. Si va a federar un sitio de ArcGIS Server con un portal de ArcGIS Enterprise, debe solicitar un certificado a una CA de confianza y configurar el portal para que lo utilice. (Para obtener más información, consulte Prácticas recomendadas de seguridad.

Requisitos de Microsoft .NET Framework para la característica .NET Extension Support

La característica .NET Extension Support requiere Microsoft .NET Framework 4.5.2 o posterior. Si no se encuentra Microsoft .NET Framework 4.5.2, la característica .NET Extension Support no estará disponible para la instalación.

Si su sistema operativo incluye Microsoft .NET Framework 4.5.2, asegúrese de que está habilitado usando Características de Windows. Si su sistema operativo no incluye Microsoft .NET Framework 4.5.2, puede descargarlo desde el soporte de instalación y habilitarlo usando Características de Windows.

Microsoft Core XML Services (MSXML) 6

ArcGIS Server requiere Microsoft Core XML Services (MSXML) 6. La instalación de ArcGIS Server no se realizará si no se encuentra MSXML 6 en el equipo. Si la instalación de ArcGIS Server se realiza a través de la GUI, el proceso de instalación instalará este elemento automáticamente. Si instala ArcGIS Server de forma automática o en ciertos entornos de implementación, deberá instalar MSXML 6 por separado. El programa de instalación de MSXML 6 está disponible en <ArcGIS Server Installation folder>\Support\MSXML6\64-bit\msxml6_x64.msi.

Requisitos de geoprocesamiento

Python 2.7.18, Numerical Python 1.9.3 y Matplotlib 1.5.2 son necesarios para la compatibilidad con determinadas herramientas fundamentales de geoprocesamiento. El programa de instalación instalará estos componentes de forma automática (recomendado) si no son detectados.

Requisitos sobre el tamaño de los archivos de la página

Asegúrese de que se haya configurado un tamaño suficiente para los archivos de la página para el equipo de ArcGIS Server. Consulte con su administrador de TI o siga las prácticas recomendadas de Microsoft.

Cuando utilice ArcGIS GeoAnalytics Server, el archivo de página de Windows puede ocupar hasta tres veces la memoria RAM física disponible si se trabaja con tareas que requieren mucha memoria. Para evitar errores del sistema y que se agote el espacio en disco, desplace el archivo de página a un volumen que disponga como mínimo de tres veces el espacio disponible de memoria RAM física.

Navegadores web compatibles

ArcGIS Server Manager requiere uno de los siguientes navegadores web:

  • Google Chrome
  • Mozilla Firefox
  • Microsoft Edge

Entornos de virtualización y plataformas en la nube compatibles

La compatibilidad con entornos de virtualización y de nube es la misma para todos los componentes de una implementación base de ArcGIS Enterprise. Consulte ArcGIS Enterprise en plataformas en la nube y Entornos de virtualización compatibles en los requisitos del sistema de ArcGIS Enterprise para obtener más información.

Bases de datos compatibles

Consulte los requisitos de cada base de datos que se pueda registrar en sitios de ArcGIS Server:

Requisitos de la versión del software

Si el sitio ArcGIS Server actúa como servidor de alojamiento para una implementación de ArcGIS Enterprise, la versión de software de ArcGIS Server debe ser la misma que la de los otros componentes de ArcGIS Enterprise básicos.

Cuando se instalan los clientes de ArcGIS Engine o ArcGIS Desktop en el mismo equipo que ArcGIS Server, los clientes de ArcGIS deben tener la misma versión de software que ArcGIS Server. Por lo tanto, si actualiza ArcGIS Server a la versión 10.9 u otra posterior, debe mover los clientes de ArcGIS Engine y ArcGIS Desktop a otro equipo.

No tiene que actualizar ni moverArcGIS Pro si está instalado en el mismo equipo que ArcGIS Server.