Skip To Content

Compatibilité du portail avec les versions antérieures d'ArcGIS

Cette rubrique répond à certaines questions qui reviennent fréquemment au sujet de la compatibilité de Portal for ArcGIS avec les versions antérieures d'ArcGIS.

Je souhaite fédérer mon site ArcGIS Server avec Portal for ArcGIS. Ces deux produits doivent-ils être de la même version ?

Cela dépend du rôle du serveur dans votre système. Tout ArcGIS Server désigné comme serveur d’hébergement ou sous licence GeoEvent Server, GeoAnalytics Server, ou Raster Analytics Server doit correspondre à la version du portail auquel il est fédéré. Un portail de version 10.5.1 ou ultérieure peut fédérer tout autre type de serveur de version 10.5 ou ultérieure, même si leurs versions ne correspondent pas.

Puis-je configurer une version antérieure d'ArcGIS Web Adaptor avec Portal for ArcGIS ?

Non. Pour configurer ArcGIS Web Adaptor avec Portal for ArcGIS, les deux produits doivent s'exécuter dans la même version.

Puis-je installer ArcGIS 10.8 Web Adaptor (IIS) sur la même machine qu'une version antérieure d'ArcGIS Web Adaptor (IIS) ?

Oui. Depuis la version 10.2.1, vous pouvez installer une version 10.2.1 ou ultérieure d'ArcGIS Web Adaptor (IIS) sur une machine sur laquelle est installée une version antérieure d'ArcGIS Web Adaptor. Vous pouvez, par exemple, installer les versions 10.1 SP1 et 10.8 d'ArcGIS Web Adaptor sur le même serveur Web.

Comme avec les versions antérieures, la version d'ArcGIS Web Adaptor doit toujours correspondre à celle de Portal for ArcGIS. Par exemple, vous ne pouvez pas configurer une version 10.8 d'ArcGIS Web Adaptor avec une version antérieure de Portal for ArcGIS.

Pour mettre à niveau une version précédente d'ArcGIS Web Adaptor (IIS) vers 10.8, vous devez désinstaller la version précédente et installer la version 10.8. Après avoir installé la version 10.8, vous devez configurer ArcGIS Web Adaptor avec Portal for ArcGIS.

Pour en savoir plus, voir Installer ArcGIS Web Adaptor (IIS).

Héritage :

avant la version 10.2.1, tous les adaptateurs Web installés sur un serveur Web unique devaient porter le même numéro de version. Lorsque vous exécutiez le programme d'installation, tous les adaptateurs Web étaient mis à niveau.

Puis-je utiliser une version antérieure d'ArcGIS Desktop pour publier ou administrer des éléments s'exécutant sur Portal for ArcGIS 10.8 ?

Oui. Vous pouvez utiliser des versions antérieures d'ArcGIS Desktop pour publier ou administrer des éléments s'exécutant sur Portal for ArcGIS 10.8, à condition qu'ArcGIS Desktop soit de version 10.2 ou ultérieure.

En revanche, vous ne pouvez pas utiliser la version 10.1 SP1 ou une version antérieure d'ArcGIS Desktop pour publier ou administrer des éléments s'exécutant sur Portal for ArcGIS 10.8.

Si j'utilise une version antérieure d'ArcGIS Desktop, puis-je visualiser et utiliser des services s'exécutant sur Portal for ArcGIS 10.8 ?

Oui. Le plus souvent, vous pouvez ajouter des services 10.8 à des versions antérieures à ArcGIS Desktop. La structure et le format essentiels des requêtes de services Web comprises par les services n'ont pas changé dans la version 10.8. Toutefois, si vous vous connectez à partir d'une version antérieure à ArcGIS Desktop, vous devez vous connecter à Portal for ArcGIS, et non au site ArcGIS 10.8 for Server fédéré pour afficher les services.

Sachez que vous pouvez uniquement vous connecter à partir des versions antérieures d'ArcGIS Desktop à Portal for ArcGIS 10.8 à l'aide des options de connexion prises en charge dans la version d'ArcGIS Desktop que vous utilisez. Par exemple, vous ne pouvez pas utiliser des connexions avec une authentification Windows intégrée pour vous connecter à Portal for ArcGIS 10.8 à partir d'ArcGIS 10.1 for Desktop, car les connexions avec une authentification Windows intégrée n'étaient pas prises en charge dans ArcGIS 10.1 for Desktop.

Quel est le chemin de migration des versions antérieures de Portal for ArcGIS vers la version 10.8 ?

L'exécution du programme d'installation de la version 10.8 assure la mise à niveau automatique de votre déploiement existant de Portal for ArcGIS vers la version 10.8. La mise à niveau ne migre pas les comportements personnalisés que vous avez configurés pour votre portail, tells que les propriétés que vous avez modifiées dans config.js. Vous êtes responsable de la sauvegarde et de la restauration de toute personnalisation entre les versions. Pour découvrir comment mettre à niveau une version antérieure de Portal for ArcGIS vers 10.8, reportez-vous à la rubrique A propos de la mise à niveau de Portal for ArcGIS.

La migration vers la version Portal for ArcGIS 10.8 à partir d'une version antérieure à 10.2 n'est possible que par l'intermédiaire des Services professionnels Esri.