Skip To Content

Configuration système requise pour ArcGIS Enterprise SDK 10.9

Les configurations système et matérielle requises pour exécuter ArcGIS Enterprise SDK sont répertoriées ci-après.

Nous vous recommandons de prendre connaissance de la notice d’obsolescence pour déterminer si vos composants matériels et logiciels sont toujours compatibles avec la version actuelle d’ArcGIS.

Configuration requise concernant les systèmes d'exploitation

Les systèmes d’exploitation 64 bits suivants possèdent la configuration système minimale requise. Les systèmes d'exploitation 32 bits ne sont pas pris en charge ; l'installation ne s'effectue que si le système d'exploitation est de type 64 bits.

Système d'exploitation pris en chargeDernière mise à jour ou dernier Service Pack testés

Windows Server 2019 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2016 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2012 R2 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2012 Standard et Datacenter

Mise à jour de février 2021

Système d'exploitation pris en chargeDernière mise à jour ou dernier Service Pack testés

Windows 10 Professionnel et Entreprise (64 bits [EM64T])

Mise à jour de février 2021

Windows 8,1 Professionnel et Entreprise (64 bits [EM64T])

Mise à jour de février 2021

Remarque :

  • Les mises à jour ou Service Packs antérieurs ou futurs de ces systèmes d’exploitation sont pris en charge, sauf indication contraire. La version et les mises à jour du système d'exploitation doivent également être prises en charge par le fournisseur du système d'exploitation.
  • L’option Desktop Experience (Expérience de bureau) est nécessaire sur toutes les versions de Windows Server.
  • Windows 10 et 8.1 peuvent uniquement être utilisés pour les tests de base et le développement d’applications. Ils ne sont pas recommandés pour un déploiement dans un environnement de production.

Espace disque requis

Enterprise SDK avec toutes les fonctionnalités .NET sur Microsoft Windows requiert environ 550 Mo d’espace disque.

Enterprise SDK avec toutes les fonctionnalités JAVA requiert environ 250 Mo d’espace disque.

Configuration requise pour les solutions de développeurs (SDK)

Plateforme de développementEnvironnement IDE pris en charge et recommandéConfiguration requise pour SDK

.NET

Les modèles Visual Studio (qui contiennent le code réutilisable) sont fournis avec Enterprise SDK pour la plateforme .NET et sont pris en charge dans l’IDE indiqué ci-après.

  • Microsoft Visual Studio 2019 (C#, VB.NET) Community, Professional, Enterprise
  • Microsoft Visual Studio 2017 (C#, VB.NET) Community, Professional, Enterprise

ArcGIS Server est requis pour le déploiement d’un SOE, et ArcGIS Pro est requis pour la publication de services de carte. Toutefois, il n’est pas nécessaire d’installer ArcGIS Server et ArcGIS Pro sur la même machine que ArcGIS Enterprise SDK ; ils peuvent se trouver sur des machines distantes.

Microsoft .NET Framework 4.5.2 ou version ultérieure

Java

ArcGIS Enterprise SDK utilise la structure Maven pour la conception et la gestion de projets Java. Il est possible d’utiliser la plupart des environnements IDE Java qui prennent en charge la structure Maven et le JDK version 11, notamment IntelliJ IDEA, Eclipse IDE ou NetBeans. Les environnements IDE documentés et recommandés sont les suivants :

  • IntelliJ IDEA Ultimate (version 2020.3.1 ou ultérieure)
  • IntelliJ IDEA Community (version 2020.3.1 ou ultérieure)
  • Eclipse IDE for Java Developers (version 2020-12 ou ultérieure)
  • Eclipse IDE for Java EE Developers (version 2020.12 ou ultérieure)

ArcGIS Server est requis pour le déploiement d’un SOE ou d’un SOI, et ArcGIS Pro est requis pour la publication de services de carte. Toutefois, il n’est pas nécessaire d’installer ArcGIS Server et ArcGIS Pro sur la même machine que ArcGIS Enterprise SDK ; ils peuvent se trouver sur des machines distantes.

La version 11.0.9 du Java Development Kit (JDK) ou les versions ultérieures du JDK 11 sont prises en charge pour la création d’un SOE et d’un SOI. La création d’un SOE ou d’un SOI avec Java 12 ou version ultérieure n’est pas prise en charge.

Maven 3.6.3 ou version ultérieure est pris en charge.