Skip To Content

Configuration système requise pour ArcObjects SDK 10.9

Consultez le support technique Esri pour en savoir plus sur la Esri stratégie de prise en charge des environnements.

Conseil :

Pour les versions ArcGIS antérieures, reportez-vous à la configuration requise sur le site Web ArcGIS Desktop.

Plateformes Microsoft Windows prises en charge*

Systèmes d'exploitation pris en chargeDernière mise à jour ou dernier Service Pack testésArcObjects SDK for the Java PlatformArcObjects SDK for the Microsoft .NET Framework**

Windows 10 Professionnel et Entreprise (64 bits [EM64T])

Mise à jour de février 2021

Pris en charge

Pris en charge

Windows 8.1 Basic, Pro, and Enterprise (32 bit and 64 bit [EM64T])

Mise à jour de février 2021

Pris en charge

Pris en charge

Windows Server 2019 Standard et Datacenter

Mise à jour de février 2021

Pris en charge

Pris en charge

Windows Server 2016 Standard et Datacenter

Mise à jour de février 2021

Pris en charge

Pris en charge

Windows Server 2012 R2 Standard et Datacenter

Mise à jour de février 2021

Pris en charge

Pris en charge

Windows Server 2012 Standard et Datacenter

Mise à jour de février 2021

Pris en charge

Pris en charge

Remarque :
Les mises à jour ou Service Packs antérieurs ou futurs de ces versions de système d’exploitation sont pris en charge, sauf indication contraire. La version et les mises à jour du système d'exploitation doivent également être prises en charge par le fournisseur du système d'exploitation.

*Reportez-vous à la section Configuration système requise et limitations des systèmes d’exploitation pour connaître les exigences supplémentaires et obtenir des informations.

**Microsoft .NET Framework requiert Visual Studio 2017 ou Visual Studio 2019. Utilisez les liens suivants pour consulter la configuration système requise pour Microsoft Visual Studio :

Configuration matérielle

Espace disque requis

SDK ArcObjectsEspace disque

ArcObjects SDK for Java Windows

676 Mo

ArcObjects SDK for the Microsoft .NET Framework

434 Mo

Configuration requise pour les solutions de développeurs (SDK)

SDK ArcObjectsEnvironnement IDE pris en charge et recommandéConfiguration requise pour le SDK

ArcObjects SDK for Java Windows

Des plug-ins IDE pour développeurs, qui fournissent un environnement de développement amélioré par l’intermédiaire de modèles, d’extraits de code et d’assistants de projet, sont fournis avec ArcObjects SDK for the Java Platform et sont pris en charge dans les IDE indiqués ci-après. (Remarque : les utilisateurs de Visual Beans doivent installer manuellement Visual Editor.)

  • Eclipse IDE for Java Developers (version 2020-12 ou ultérieure)
  • Eclipse IDE for Java EE Developers (version 2020-12 ou ultérieure)

ArcGIS Server est requis pour les développements avec ArcObjects SDK Java.

La version 8 Update 275 du Java Development Kit (JDK) ou les versions ultérieures du JDK 8 sont prises en charge pour la création d’un SOE et d’un SOI. La création d’un SOE ou d’un SOI avec Java 9 ou version ultérieure n’est pas prise en charge.

ArcObjects SDK for the Microsoft .NET Framework

Microsoft Visual Studio 2019 (C#, VB.NET) Community, Professional, Enterprise

Microsoft Visual Studio 2017 (C#, VB.NET) Community, Professional, Enterprise

Microsoft .NET Framework 4.5.2 ou version ultérieure

Configuration système requise et limitations des systèmes d'exploitation

Toutes les plateformes

Windows