Skip To Content

ArcGIS 10.9.1 и требования ArcGIS Pro 2.9 для Microsoft SQL Server

ArcGIS поддерживают подключения к базам данных Microsoft SQL Server и многопользовательским базам геоданных в SQL Server.

Подсказка:

Для версий до ArcGIS 10.9 и ArcGIS Pro 2.8 см. Системные требования на веб-сайте ArcGIS Desktop.

Откройте сайт технической поддержки Esri для информации о Поддерживаемой политике средыEsri.

Поддерживаемые версии баз данных

Следующие версии Microsoft SQL Server - минимальные сертифицированные версии, поддерживающиеся в ArcGIS. Пакеты обновлений SQL Server и другие обновления для этих версий поддерживаются, но не сертифицированы.

Версии Enterprise/Standard/Developer*

Microsoft SQL Server 2019 (64-разрядный)

Microsoft SQL Server 2019 на Linux (64-разрядный)

Microsoft SQL Server 2017 (64-разрядный)

Microsoft SQL Server 2017 на Linux (64-разрядный)

Microsoft SQL Server 2016 (64-разрядный)

Версии Express

Microsoft SQL Server 2019 (64-разрядный)

Microsoft SQL Server 2017 (64-разрядный)

Microsoft SQL Server 2016 (64-разрядный)

Примечание:

* Версия для разработчиков поддерживается только в непроизводственных средах.

Поддерживаемые операционные системы

Если ваша СУБД установлена на сервере, где инсталлированы продукты ArcGIS, операционная система сервера должна соответствовать системным требованиям для продуктов ArcGIS, а также требованиям к ОС для вашей версии SQL Server.

Если ваша база данных не установлена на том же сервере, что и продукт ArcGIS, см. документацию Microsoft для требований операционной системы вашей версии SQL Server.

Поддержка облака

Информацию о поддержке сервисов баз данных и баз данных, развернутых в облаке см. Требования для использования ArcGIS с базами данных в облаке.

Программы, необходимые для подключения к SQL Server

Любые клиентские компьютеры, подключающиеся напрямую к SQL Server, должны иметь установленный клиент SQL Server. Клиентские приложения SQL Server для Microsoft Windows и Linux распространяются Microsoft. Клиенты SQL Server для Windows также доступны на сайте My Esri. Необходимо установить клиентское приложение той же или более новой версии, что и база данныхSQL Server, к которой вы подключаетесь. Если вы обновляете SQL Server, одновременно обновите клиенты SQL Server. Если версия SQL Server более не поддерживается ArcGIS, соответствующая библиотека клиента SQL Server также более поддерживаться не будет.

Поддерживаются следующие клиенты SQL Server:

  • SQL Server 2019
    • Драйвер ODBC Microsoft 17 для SQL Server
  • SQL Server 2017
    • Драйвер ODBC Microsoft 17 для SQL Server
  • SQL Server 2016
    • Драйвер ODBC Microsoft 17 для SQL Server
    • Драйвер ODBC Microsoft 13 или 13.1 для SQL Server