Skip To Content

Требования ArcGIS 11.0 и ArcGIS Pro 3.0 для Oracle

ArcGIS Pro и ArcGIS Enterprise на Microsoft Windows и Linux поддерживают подключения к базам данных Oracle и многопользовательским базам геоданных в Oracle.

Подсказка:

Для версий до ArcGIS 10.9 и ArcGIS Pro 2.8 см. раздел Системные требования на веб-сайте ArcGIS Desktop.

Откройте сайт технической поддержки Esri для информации о Поддерживаемой политике средыEsri.

Поддерживаемые версии баз данных

Следующие версии Oracle - минимальные сертифицированные патч-версии, поддерживающиеся в ArcGIS. Поддерживаются более новые пакеты исправлений Oracle к этим версиям, в том числе уровни наборов патчей и патчи Interim (One-Off).

Standard 2 (SE2)/Enterprise (EE) Editions:

Oracle 12c R1 (64-разрядная) 12.1.0.2

Oracle 12c R2 (64-разрядная) 12.2.0.1

Oracle 19c (64-разрядная) 19.3.0.0

Щелкните здесь, чтобы получить сведения о поддержке патчей Oracle

Поддерживаемые операционные системы

Если ваша СУБД установлена там же, где и продукты ArcGIS, операционная система должна соответствовать системным требованиям для продукта ArcGIS, а также требованиям к ОС для Oracle.

Если ваша база данных не установлена на том же сервере, что и продукт ArcGIS, см. документацию Oracle для изучения требований операционной системы вашей версии Oracle.

Дополнительные требования к библиотеке геометрии ST_Geometry

Esri поддерживает следующие 4 ОС при использовании библиотеки геометрии ST_Geometry и настройке внешней процедуры Oracle (extproc).

  • IBM AIX (64-разрядая)
  • Linux (64-разрядная)
  • Solaris (64-разрядная)
  • Microsoft Windows (64-разрядная)

Если библиотека геометрии ST_Geometry в Windows, вам потребуется установить на компьютере с базой данных Oracle последнюю версию Microsoft Visual C++ Redistributable для Visual Studio 2015, 2017, 2019 и 2022. См. раздел Последние поддерживаемые загрузки Visual C++ справочной системы Microsoft для получения дополнительных сведений.

  • Поддержка Oracle Exadata Database Machine основана на документации Oracle, что OEM ПО, поддерживающее Oracle Linux и Oracle RAC, совместимо с Oracle Exadata.
  • Новая опция Oracle 12c, Multitenant Architecture, которая заключается в том, что контейнер базы данных может содержать много сменных баз данных, поддерживается на уровне сменной базы данных. ArcGIS поддерживает ту же функциональность в сменных базах данных, как она поддерживалась в Oracle 11g R2.

Требования/ограничения базы данных

Сервис-ориентированные версии поддерживаются в Oracle 12.1.0.2 и более поздних версиях. Однако пакетные версии не поддерживаются базами геоданных в пользовательских схемах.

Необходимо установить компонент Text Oracle. Компонент Text установлен в Oracle по умолчанию; однако, если вы не производили установку по умолчанию, компонент Text может быть не установлен.

Поддержка патчей баз данных Oracle

См. документацию Oracle Support для всего набора патчей Oracle (и Interim Patch) и инструкции по установке. Esri рекомендует сделать полную резервную копию вашей базы данных Oracle до задействования наборов патчей Oracle или промежуточного патча interim. Если функциональность, которая работала до задействования патча Oracle или промежуточного патча, перестала работать, вернитесь к предыдущей версии Oracle. Если требуется, свяжитесь с поддержкой Oracle.

Поддержка облака

Информацию о поддержке сервисов баз данных и баз данных, развернутых в облаке см. Требования для использования ArcGIS с базами данных в облаке.

Программное обеспечение, необходимое для подключения к СУБД

Клиентскому компьютеру (например, на котором запущен ArcGIS Pro или ArcGIS Server) необходимы файлы клиента базы данных, соответствующие РСУБД, которую вы используете. Эти клиентские файлы доступны у соответствующих поставщиков СУБД. Более подробно см. в разделе Клиенты базы данных.

Примечание:

Рекомендуется, чтобы клиенты ArcGIS использовали новейший клиент Oracle, поддерживаемый версией базы данных Oracle, к которой вы подключаетесь.