Skip To Content

客户端与地理数据库的兼容性

可以使用各种不同的 ArcGIS 客户端软件来访问地理数据库。其中包括:

  • ArcGIS Pro(支持连接到文件和企业级地理数据库)
  • ArcMap(包括 ArcCatalogArcGlobeArcScene
  • ArcGIS Server 服务(支持连接到文件、工作组和企业级地理数据库)

兼容版本

您不必将地理数据库和 ArcGIS 客户端版本保持一致,但建议您这样做。地理数据库和客户端软件旨在实现协作,如果其中一个有过多版本且与另一个相去甚远,那么您很可能会遇到问题或意外行为。

当您在站点上混合使用多个客户端版本时尤其如此。较新的客户端可以在较旧的客户端无法访问的地理数据库中创建较新的数据集类型。对于企业级地理数据库,在两次地理数据库升级之间间隔过长时间可能意味着您必须对基础数据库进行多次升级,然后才能升级地理数据库。

企业级地理数据库的地理数据库版本存储在系统表中。它可指示用于创建或升级地理数据库的客户端版本。例如,如果您从 ArcMap 10.6.1 创建了一个企业级地理数据库,则地理数据库版本为 10.6.1。如果稍后使用 ArcGIS Pro 2.6 来升级同一个地理数据库,则地理数据库版本为 10.8.1.2.6。请注意,此地理数据库版本主要由 Esri 支持中心用于解决相关问题;它并不完全反映您可以使用的功能,因为许多地理数据库功能是在访问地理数据库的客户端中实现的,而不是在地理数据库本身中实现的。

以下规则适用于兼容性:

  • 为您的客户端和地理数据库使用受支持的 ArcGIS 版本。
  • ArcGIS 客户端还包括该客户端的 API。因此,在使用 API 访问地理数据库时,系统将应用相同的混合版本规则。
  • 使用连接至 ArcGIS Server 服务的客户端(如 ArcGIS CollectorArcGIS Survey123)时,ArcGIS Server 实际为地理数据库的客户端。对于上述情况,请确保您的 ArcGIS Server 与地理数据库版本相兼容。
  • 可以使用新版本的地理数据库打开旧版本的 ArcGIS 客户端,并在其中查询、编辑和存储数据;但是无法打开参与到新功能的数据集。当您尝试从较旧的 ArcGIS 客户端访问较新类型的数据集时,将遇到以下错误消息:

    此版本的地理数据库客户端与该数据集不兼容,因此无法打开。

    添加数据失败,数据类型不受支持。

  • 要将较新的 ArcGIS 客户端连接到较旧版本的企业级地理数据库,请将最新修补程序应用于其版本中的地理数据库(如存在此地理数据库)。
  • 必须将企业级地理数据库存储在所使用的地理数据库和 ArcGIS 版本都支持的数据库版本中。此外,您的 ArcGIS 版本还必须支持在 ArcGIS 客户端计算机上安装的数据库客户端。有关受支持的数据库和数据库客户端版本的详细信息,请参阅以下页面。请使用其他版本下拉列表,以查看有关较旧软件版本的信息。
  • 如果您使用地理数据库复制,子复本地理数据库的版本必须与父复本地理数据库的版本相同,或高于父复本地理数据库的版本。有关详细信息,请参阅复制和地理数据库版本
  • 您无法使用 ArcMap 访问参与 ArcGIS Pro 特定功能的数据集。例如,您无法从 ArcMap 访问分支版本化数据集、公共设施网络或具有属性规则的数据集。
  • 如果将地理数据库升级到 10.8. 或更高版本并在 ArcGIS Pro 中使用升级数据集地理处理工具升级尺寸注记要素类,则无法再从 ArcMap 10.7 及更高版本中打开它。

何时需要升级地理数据库?

最好使地理数据库和客户端版本尽可能保持接近。有时,您必须升级地理数据库。如果出现以下情况之一,则必须升级地理数据库:

  • 您使用的客户端版本无法连接到您想要使用的地理数据库版本。对于企业级地理数据库,您正在使用的客户端版本可能无法连接到您正在使用的数据库管理系统版本,并且您需要同时升级数据库和地理数据库以从较新的客户端进行连接。
  • 您想要使用仅在较新版本地理数据库中提供的功能。检查每个版本的 ArcGIS Pro 的新特性,以获取有关地理数据库中新功能和数据集类型的信息。

有关地理数据库升级的详细信息,请参阅适合您所使用的地理数据库类型的升级主题:

文件地理数据库

升级文件地理数据库或个人地理数据库

工作组级地理数据库

升级工作组级地理数据库

Db2Linux 系统上的 Microsoft Windows 中的地理数据库

升级 Db2 中的地理数据库

z 操作系统上 Db2 中的地理数据库

升级 z/OS 的 Db2 中的地理数据库

Informix 中的地理数据库

升级 Informix 中的地理数据库

Oracle 中的地理数据库

升级 Oracle 中的地理数据库

PostgreSQL 中的地理数据库

升级 PostgreSQL 中的地理数据库

SAP HANA 中的地理数据库

升级 SAP HANA 中的地理数据库

SQL Server 中的企业级地理数据库

升级 SQL Server 中的地理数据库

地理数据库版本

有时文档会指出,您需要拥有特定版本的地理数据库才能利用特定功能块。通常,该版本将列为地理数据库的 10.x 版本。如前所述,当您在 ArcGIS Pro 中创建或升级企业级地理数据库时,地理数据库版本号将是 10.x 和 ArcGIS Pro 版本号的组合。下表可帮助您确定将使用 ArcGIS Pro 创建或升级到的地理数据库版本:

ArcGIS Pro 版本等效的 10.x 版本地理数据库版本

2.2

10.6.1

10.6.1.2.2

2.3

10.7

10.7.0.2.3

2.4

10.7.1

10.7.1.2.4

2.5

10.8

10.8.0.2.5

2.6

10.8.1

10.8.1.2.6