Skip To Content

ArcGIS Enterprise SDK 10.8.x 系统要求

下面列出了运行 ArcGIS Enterprise SDK 的系统规范和硬件要求。

建议您检查弃用通知,以确定硬件和软件组件是否仍与 10.8 和 10.8.1 版本兼容。

操作系统要求

以下各 64 位操作系统满足最低的操作系统要求。不支持 32 位操作系统;仅在操作系统为 64 位时才可执行安装程序。

受支持的操作系统经测试的最新更新或补丁包

Windows Server 2019 标准版和数据中心版

2020 年 6 月更新

Windows Server 2016 标准版和数据中心版

2020 年 6 月更新

Windows Server 2012 R2 标准版和数据中心版

2020 年 6 月更新

Windows Server 2012 标准版和数据中心版

2020 年 6 月更新

除非另有说明,否则这些操作系统版本之前和未来的更新或补丁包均将受到支持。同时,操作系统版本与更新也必须受到操作系统供应商的支持。

注:

所有版本的 Windows Server 都需要“桌面体验”选项。

受支持的操作系统经测试的最新更新或补丁包

Windows 10 专业版和企业版(64 位 [EM64T])

2020 年 6 月更新

Windows 8.1 专业版和企业版(64 位 [EM64T])

2020 年 6 月更新

磁盘空间要求

具有 .NET(适用于 Microsoft Windows)所有功能的 Enterprise SDK 需要大约 550 MB 的磁盘空间。

具有 Java 所有功能的 Enterprise SDK 需要大约 250 MB 的磁盘空间。

开发人员解决方案 (SDK) 要求

开发平台支持和推荐的 IDESDK 要求

.NET

Visual Studio 模板(其中包含样板代码)随 .NET 平台的 Enterprise SDK 一同提供,并适用于下列 IDE。

  • Microsoft Visual Studio 2019(C#、VB.NET)社区,专业版、企业版
  • Microsoft Visual Studio 2017(C#、VB.NET)社区,专业版、企业版

部署 SOE 时需要 ArcGIS Server,发布地图服务时需要 ArcGIS Pro。但是,无需在安装 ArcGIS Enterprise SDK 的同一计算机上安装 ArcGIS ServerArcGIS Pro;可将其安装在远程计算机上。

Microsoft .NET Framework 4.5.2 或更高版本

Java

在 ArcGIS 10.8.1 中,ArcGIS Enterprise SDK 使用 Maven 框架进行 Java 工程构建和管理。可以使用支持 Maven 框架和 JDK 11 的大多数 Java IDE,例如 IntelliJ IDEA、Eclipse IDE 或 NetBeans。记录和建议的 IDE 如下:

  • IntelliJ IDEA Ultimate(2019.3.4 版本或更高版本)
  • IntelliJ IDEA Community(2019.3.4 版本或更高版本)
  • 适用于 Java 开发人员的 Eclipse IDE(2019-12 版本或更高版本
  • 适用于 Java EE 开发人员的 Eclipse IDE(2019-12 版本或更高版本

在 ArcGIS 10.8 中,Eclipse 插件随 ArcGIS Enterprise SDK for the Java Platform 一同提供。Eclipse 插件通过模板、工程向导和内置示例为开发人员提供了增强的体验。支持的 IDE 如下所示:

  • Eclipse Photon (4.8) IDE for Java Developers
  • Eclipse Oxygen (4.8) IDE for Java EE Developers
  • Eclipse Oxygen (4.7) IDE for Java Developers
  • Eclipse Oxygen (4.7) for Java EE Developers

需要使用 ArcGIS Server 部署 SOE 或 SOI,需要使用 ArcGIS Pro 发布服务。但是,无需在安装 ArcGIS Enterprise SDK 的同一计算机上安装 ArcGIS ServerArcGIS Pro;可将其安装在远程计算机上。

在 ArcGIS 10.8.1 中,构建 SOE 和 SOI 时,支持 Java Development Kit (JDK) 11.0.6 版本或更高版本的 JDK 11。不支持使用 Java 12 或更高版本构建 SOE 或 SOI。支持 Maven 3.6.1 或更高版本。

在 ArcGIS 10.8 中,构建 SOE 和 SOI 时,支持 Java Development Kit (JDK) 8.Update 191 版本或更高版本的 JDK 8。不支持使用 Java 9 或更高版本构建 SOE 或 SOI。