Skip To Content

ArcGIS Web Adaptor 10.9.1 系统要求

下面列出了运行 ArcGIS Web Adaptor 的系统和硬件要求。 有关先前版本的信息,请参阅 Esri 支持

要确定硬件和软件是否仍与当前 ArcGIS 版本兼容,请检查弃用通知

ArcGIS Web Adaptor (IIS) 的 Web 服务器和操作系统要求

支持以下 Microsoft Windows 操作系统。 支持将这些操作系统上可用的 IIS Web 服务器版本与 ArcGIS Web Adaptor (IIS) 配合使用。 除非另有说明,否则针对这些操作系统和 web 服务器的更新均受支持。 同时,操作系统版本与更新也必须受到应用程序或 Web 服务器供应商的支持。

受支持的操作系统经测试的最新更新或补丁包

Windows Server 2022 标准版和数据中心版

Windows Server 2019 标准版和数据中心版

2021 年 9 月更新

Windows Server 2016 标准版和数据中心版

2021 年 9 月更新

Windows Server 2012 R2 标准版和数据中心版

2021 年 9 月更新

Windows Server 2012 标准版和数据中心版

2021 年 9 月更新

开发环境

受支持的操作系统经测试的最新更新或补丁包

Windows 11 专业版和企业版(64 位 [EM64T])

2021 年 11 月更新

Windows 10 专业版和企业版(64 位 [EM64T])

2021 年 9 月更新

Windows 8.1 专业版和企业版(64 位 [EM64T])

2021 年 9 月更新

注:

  • 所有版本的 Windows Server 都需要“桌面体验”选项。
  • Windows 11、10 和 8.1 仅适用于基本测试和应用程序开发用途。 不建议在生产环境中对其进行部署。

ArcGIS Web Adaptor (Java Platform) 的应用程序和 Web 服务器与操作系统要求

这些操作系统支持以下应用程序和 Web 服务器:

  • Apache Tomcat 8.5.35 和 9.0.19
  • GlassFish 4.1.1
  • IBM WebSphere 8.5.5.9 和 9
  • JBoss Enterprise Application Platform 7
  • Oracle WebLogic 12c R1 和 R2

除非另有说明,否则针对这些应用程序或 Web 服务器的更新均受支持。

受支持的操作系统经测试的最新更新或补丁包

Windows Server 2022 标准版和数据中心版

Windows Server 2019 标准版和数据中心版

2021 年 9 月更新

Windows Server 2016 标准版和数据中心版

2021 年 9 月更新

Windows Server 2012 R2 标准版和数据中心版

2021 年 9 月更新

Windows Server 2012 标准版和数据中心版

2021 年 9 月更新

注:

注意以下事项:

  • 所有版本的 Windows Server 都需要“桌面体验”选项。
  • 不支持名称中带有下划线 (_) 的计算机。 多个广泛应用的 Internet 主机名规范已将下划线指定为非标准字符。 虽然 Microsoft Windows 允许将下划线用于计算机名,但当您与其他服务器和平台进行交互时,仍会产生问题。 因此,如果服务器的主机名中含有下划线,则将不会继续进行安装。

Java 支持(面向 Windows

ArcGIS Web Adaptor 10.8 及更高版本支持 Java 8、Java 11 和 Java 12。

旧版本:

ArcGIS Web Adaptor 10.4.x 支持 Java 7 和 8。ArcGIS Web Adaptor 10.5.x 和 10.6.x 仅支持 Java 8。ArcGIS Web Adaptor 10.7.x 支持 Java 8、Java 11 和 Java 12。

最大安装实例数

最多可在一台计算机上安装 21 个 ArcGIS Web Adaptor (IIS) 实例。 如果需要更多实例,请在另一台计算机上进行安装。

如果您的计算机上安装了较早版本,无须卸载它们。 例如,在同一台计算机上可以安装 5 个 ArcGIS Web Adaptor 10.4 实例和 21 个 ArcGIS Web Adaptor 10.9.1 实例。 最大值仅适用于软件版本相同的实例。

Microsoft .NET Framework 4.5.2 支持

ArcGIS Web Adaptor (IIS) 需要安装 Microsoft .NET Framework 4.5.2 或更高版本。 如果您的操作系统已安装 Microsoft .NET Framework 4.5.2,则请确保已使用 Windows 功能将其启用。 如果您的操作系统未安装 Microsoft .NET Framework 4.5.2,则可从安装介质上进行下载并使用 Windows 功能将其启用。

Microsoft IIS 所需的组件

Microsoft Internet Information Server (IIS) 必须与特定 IIS 组件一同启用。 如果未检测到 IIS 且未启用特定的 IIS 组件,则安装程序将无法继续。

如果已安装 IIS 8.0、8.5 或 10,但是缺少所需的 IIS 组件,则安装程序将显示 IIS 要求验证对话框。 您可以在其中选择允许安装程序自动启用所有缺少的必需 IIS 组件。 为此,请单击我同意

注:

如果您打算静默安装 ArcGIS Web Adaptor,则必须手动启用所有所需 IIS 组件。 在执行静默安装时,安装程序不会自动启用缺少的 IIS 组件。

要了解如何在您的操作系统中启用 IIS 以及如何有选择地自行启用缺少的 IIS 8.0、8.5 或 10 组件,请参阅以下主题:

支持的 Web 浏览器

Web Adaptor 配置向导支持以下 Web 浏览器:

  • Google Chrome
  • Mozilla Firefox
  • Microsoft Edge

受支持的虚拟化环境和云平台

对于基础 ArcGIS Enterprise 部署的所有组件,虚拟化和云环境支持均相同。 有关详细信息,请参阅 ArcGIS Enterprise 系统要求中的云平台上的 ArcGIS Enterprise受支持的虚拟化环境