Skip To Content

ArcGIS 10.9.1 and ArcGIS Pro 2.9 requirements for IBM Db2

ArcGIS Pro and ArcGIS Server support connections to IBM Db2 databases and enterprise geodatabases in Db2.

Note:

This is the last ArcGIS release to support Db2 on the z operating system (z/OS).

For versions prior to ArcGIS 10.9 and ArcGIS Pro 2.7, see the system requirements on the ArcGIS Desktop website.

Visit Esri Technical Support for information on the Esri Supported Environment Policy.

Supported database versions

The following IBM Db2 releases and fix pack versions are the minimum certified and supported with ArcGIS. Newer fix pack versions on these versions are supported but not certified.

IBM Db2 Version 11.1 Mod 4 Fix Pack 5

IBM Db2 Version 11.5

IBM Db2 Version 11 for z/OS

IBM Db2 Version 12 for z/OS

ArcGIS Pro does not support IBM Db2 for z/OS.

Database requirements and limitations

  • Your Db2 database on Linux, UNIX, or Microsoft Windows must be configured to use UTF-8 encoding.
  • Db2 is not supported as a data store item in an ArcGIS Enterprise portal.

Requirements and limitations that apply to specific versions of Db2 are as follows:

IBM Db2 V11.1 (64 bit)

  • Minimum required service packs/patches: Mod 4 Fix Pack 5.
  • Db2 Spatial Extender is included in the Db2 database product media.
  • Recommended service packs/patches: n/a.

IBM Db2 V11.5 (64 bit)

  • Minimum required service packs/patches: Fix Pack 0.
  • Db2 Spatial Extender is included in the Db2 database product media.
  • Recommended service packs/patches: n/a.

IBM Db2 V11 for z/OS

  • Required service packs/patches: PI45211/UI32479(J2AG310).
  • Required add-ons: IBM Spatial Support for Db2 11 for z/OS-Db2 Accessories Suite.
  • The following limitations only apply to Db2 z/OS databases that have not been enabled as a geodatabase:
    • Feature services are not supported.
    • Geoprocessing operations that write information to the database are not supported.
    • Branch versioning is not supported.
    • Feature binning is not supported.

IBM Db2 V12 for z/OS

  • Required add-ons: IBM Spatial Support for Db2 12 for z/OS-Db2 Accessories Suite.
  • The following limitations only apply to Db2 z/OS databases that have not been enabled as a geodatabase:
    • Feature services are not supported.
    • Geoprocessing operations that write information to the database are not supported.
    • Branch versioning is not supported.
    • Feature binning is not supported.

Supported operating systems

  • If your database management system is installed on a server where ArcGIS products are installed, the server operating system must meet the ArcGIS product system requirements as well as the operating system requirements for your Db2 version.
  • If your database is not installed on the same server as an ArcGIS product, see the IBM documentation for operating system requirements for your Db2 version.

ArcGIS is tested and certified on Db2 Enterprise Server Edition. Other versions of Db2, such as Db2 Workgroup Server Edition and Db2 Personal Edition, share a common code base and are supported as long as they meet the ArcGIS Server requirements.

Cloud support

See Requirements for using ArcGIS with databases in the cloud for information on support for database services and databases deployed in the cloud.

Software required to connect to a DBMS

Your client machine (for example, the one running ArcGIS Pro, ArcMap, or ArcGIS Server) must have the appropriate database client files installed for the RDBMS you are using. These client files are available from their respective RDBMS vendors. See Database clients for more information.