Skip To Content

Configuration requise pour ArcGIS 10.9.1 et ArcGIS Pro 2.9 pour Microsoft SQL Server

ArcGIS prend en charge les connexions aux bases de données Microsoft SQL Server et aux géodatabases d’entreprise dans SQL Server.

Conseil :

Pour les versions antérieures à ArcGIS 10.9 et ArcGIS Pro 2.8, reportez-vous à la configuration système requise sur le site Web ArcGIS Desktop.

Consultez le support technique Esri pour en savoir plus sur la Esri stratégie de prise en charge des environnements.

Versions de bases de données prises en charge

Les versions suivantes de Microsoft SQL Server correspondent aux versions certifiées minimales prises en charge avec ArcGIS. Les Service Packs SQL Server et les mises à jour cumulatives de ces versions sont pris en charge, mais ne sont pas certifiés.

Éditions Enterprise/Standard/Developer*

Microsoft SQL Server 2019 (64 bits)

Microsoft SQL Server 2019 sur Linux (64 bits)

Microsoft SQL Server 2017 (64 bits)

Microsoft SQL Server 2017 sur Linux (64 bits)

Microsoft SQL Server 2016 (64 bits)

Editions Express

Microsoft SQL Server 2019 (64 bits)

Microsoft SQL Server 2017 (64 bits)

Microsoft SQL Server 2016 (64 bits)

Remarque :

*L’édition Developer est seulement prise en charge dans les environnements hors production.

Systèmes d'exploitation pris en charge

Si votre système de gestion de base de données est installé sur un serveur sur lequel des produits ArcGIS sont installés, le système d’exploitation du serveur doit présenter la configuration système requise pour les produits ArcGIS ainsi que la configuration requise pour le système d’exploitation de votre version de SQL Server.

Si votre base de données n’est pas installée sur le même serveur qu’un produit ArcGIS, consultez la documentation Microsoft pour connaître la configuration de système d’exploitation requise pour votre version SQL Server.

Prise en charge du cloud

Consultez Configuration requise pour utiliser ArcGIS avec des bases de données dans le cloud pour en savoir plus sur le support pour les services de base de données et les bases de données déployés dans le cloud.

Logiciel requis pour se connecter à SQL Server

Les machines clientes qui se connectent directement à SQL Server doivent être dotées d’un client SQL Server. Les clients SQL Server pour Microsoft Windows et Linux sont distribués par Microsoft. Les clients SQL Server pour Windows sont également disponibles sur My Esri. Vous devez installer un client d’une version équivalente ou supérieure à celle de la base de données SQL Server à laquelle vous voulez vous connecter. Si vous mettez à niveau SQL Server, procédez par la même occasion à la mise niveau des clients SQL Server. Lorsqu’une version de SQL Server n’est plus prise en charge par ArcGIS, la bibliothèque de client SQL Server correspondante n’est plus prise en charge.

Les clients SQL Server pris en charge sont les suivants :

  • SQL Server 2019
    • Pilote ODBC Microsoft 17 pour SQL Server
  • SQL Server 2017
    • Pilote ODBC Microsoft 17 pour SQL Server
  • SQL Server 2016
    • Pilote ODBC Microsoft 17 pour SQL Server
    • Pilote ODBC Microsoft 13 ou 13.1 pour SQL Server