Skip To Content

Configuration système requise pour ArcGIS Web Adaptor 10.9

Les configurations système et matérielle requises pour l’exécution de ArcGIS Web Adaptor sont répertoriées ci-dessous. Pour plus d’informations sur les versions antérieures, consultez le support technique Esri.

Prenez connaissance de la notice d’obsolescence pour déterminer si vos matériels et logiciels sont toujours compatibles avec la version actuelle d’ArcGIS.

Configuration requise concernant les serveurs Web et les systèmes d’exploitation pour ArcGIS Web Adaptor (IIS)

Les systèmes d’exploitation Microsoft Windows suivants sont pris en charge. Les versions du serveur Web IIS disponibles sur ces systèmes d’exploitation sont compatibles avec ArcGIS Web Adaptor (IIS). Les mises à jour de ces systèmes d’exploitation et de ces serveurs Web sont prises en charge, sauf mention contraire. La version et les mises à jour du système d’exploitation doivent également être prises en charge par le fournisseur des serveurs d’applications/Web.

Système d'exploitation pris en chargeDernière mise à jour ou dernier Service Pack testés

Windows Server 2019 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2016 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2012 R2 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2012 Standard et Datacenter

Mise à jour de février 2021

Système d'exploitation pris en chargeDernière mise à jour ou dernier Service Pack testés

Windows 10 Professionnel et Entreprise (64 bits [EM64T])

Mise à jour de février 2021

Windows 8,1 Professionnel et Entreprise (64 bits [EM64T])

Mise à jour de février 2021

Remarque :

  • L’option Desktop Experience (Expérience de bureau) est nécessaire sur toutes les versions de Windows Server.
  • Windows 10 et 8.1 peuvent uniquement être utilisés pour les tests de base et le développement d’applications. Ils ne sont pas recommandés pour un déploiement dans un environnement de production.

Configuration requise concernant les serveurs d’applications/Web et les systèmes d’exploitation pour ArcGIS Web Adaptor (Java Platform)

Les serveurs d’applications/Web suivants sont pris en charge sur ces systèmes d’exploitation :

  • Apache Tomcat 7.0.92, 8.5.35 et 9.0.19
  • GlassFish 4.1.1
  • IBM WebSphere 8.5.5.9 et 9
  • JBoss Enterprise Application Platform 7
  • Oracle WebLogic 12c R1 et R2

Les mises à jour de ces serveurs d'applications/web sont prises en charge, sauf mention contraire.

Système d'exploitation pris en chargeDernière mise à jour ou dernier Service Pack testés

Windows Server 2019 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2016 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2012 R2 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2012 Standard et Datacenter

Mise à jour de février 2021

Remarque :

Vérifiez les éléments suivants :

  • L’option Desktop Experience (Expérience de bureau) est nécessaire sur toutes les versions de Windows Server.
  • Les traits de soulignement (_) ne sont pas acceptés dans les noms de machine. Plusieurs spécifications de noms d’hôtes Internet désignent le caractère de soulignement comme étant non standard. Bien que Microsoft Windows vous permette d’utiliser le caractère de soulignement dans un nom de machine, cela risque de provoquer des problèmes lorsque vous travaillez avec d’autres serveurs et plateformes. Ainsi, l’installation ne s’exécute pas sur les serveurs dont le nom d’hôte inclut un caractère de soulignement.

Prise en charge de Java (pour Windows)

ArcGIS Web Adaptor 10.8.x et 10.9 prend en charge Java 8, Java 11 et Java 12.

Héritage :

ArcGIS Web Adaptor 10.4.x prend en charge Java 7 et 8. ArcGIS Web Adaptor 10.5.x et 10.6.x prennent uniquement en charge Java 8. ArcGIS Web Adaptor 10.7.x prend en charge Java 8, Java 11 et Java 12.

Nombre maximal d'instances d'installation

Vous pouvez installer au maximum 21 instances de ArcGIS Web Adaptor (IIS) sur une même machine. Si plus d’instances sont nécessaires, installez-les sur une autre machine.

Si des versions antérieures sont installées sur la machine, il n'est pas nécessaire de les désinstaller. Par exemple, cinq instances de ArcGIS Web Adaptor 10.4 et 21 instances de ArcGIS Web Adaptor 10.9 peuvent être installées sur une même machine. La valeur maximale s'applique uniquement aux instances de la même version logicielle.

Prise en charge de Microsoft .NET Framework 4.5.2.

ArcGIS Web Adaptor (IIS) nécessite l’installation de Microsoft .NET Framework 4.5.2 ou version ultérieure. Si votre système d’exploitation inclut Microsoft .NET Framework 4.5.2, vérifiez qu’il est activé avec les fonctionnalités de Windows. Si votre système d’exploitation n’inclut pas Microsoft .NET Framework 4.5.2, vous pouvez le télécharger à partir du support d’installation et l’activer avec les fonctionnalités de Windows.

Composants requis pour Microsoft IIS

ArcGIS Web Adaptor (IIS) prend en charge IIS dans Windows 8.1, 10, Windows Server 2012, 2012 R2, 2016 et 2019 Standard/DataCenter. Cela correspond à IIS versions 8.0, 8.5 et 10. IIS doit être activé, ainsi que certains composants spécifiques d’IIS 8.0, 8.5 et 10. Le programme d'installation ne se poursuit pas si IIS n'est pas détecté et que les composants IIS spécifiques ne sont pas activés.

Si vous avez déjà installé IIS 8.0, 8.5 ou 10 mais que des composants IIS requis manquent, le programme d’installation affiche la boîte de dialogue IIS requirements verification (Vérification de la configuration requise pour IIS). Cette boîte de dialogue permet d'autoriser l'installation à activer automatiquement tous les composants IIS requis manquants. Pour ce faire, cliquez sur I agree (J’accepte). Pour en savoir plus, reportez-vous à la section Activation automatique des composants IIS.

Remarque :

Si vous prévoyez d’effectuer une installation en mode silencieux de ArcGIS Web Adaptor, tous les composants IIS nécessaires doivent être activés manuellement. En effet, le programme d’installation n’active pas automatiquement les composants IIS requis lorsque vous effectuez une installation en mode silencieux.

Pour savoir comment activer IIS sur votre système d’exploitation et éventuellement comment activer les composants IIS 8.0, 8.5 ou 10 manquants par vous-même, consultez les rubriques suivantes :

Navigateurs Web pris en charge

L’assistant de configuration de Web Adaptor prend en charge les navigateurs Web suivants :

  • Google Chrome
  • Mozilla Firefox
  • Microsoft Edge

Plateformes cloud et environnements de virtualisation pris en charge

La prise en charge des environnements de Cloud et de virtualisation est la même pour tous les composants d’un déploiement ArcGIS Enterprise de base. Pour plus d’informations, reportez-vous aux sections ArcGIS Enterprise sur les plates-formes de Cloud et Environnements de virtualisation pris en charge de la rubrique consacrée à la configuration système requise pour ArcGIS Enterprise.