Skip To Content

Configuration requise de ArcGIS 10.9 et ArcGIS Pro 2.8 pour PostgreSQL

ArcGIS prend en charge les connexions aux bases de données PostgreSQL et aux géodatabases d’entreprise dans PostgreSQL.

Conseil :

Pour les versions ArcGIS antérieures, reportez-vous à la configuration requise sur le site Web ArcGIS Desktop.

Consultez le support technique Esri pour en savoir plus sur la Esri stratégie de prise en charge des environnements.

Versions de bases de données minimales prises en charge

Les versions suivantes de PostgreSQL et de PostGIS sont prises en charge par ArcGIS. Les versions spécifiques répertoriées correspondent à la version mineure minimale prise en charge et certifiée pour chaque version majeure prise en charge de PostgreSQL et PostGIS. De nouvelles versions mineures sont prises en charge, mais pas certifiées, sauf mention contraire. La version et les mises à jour de PostgreSQL doivent également être prises en charge par PostgreSQL Global Development Group.

Conformément à la définition de PostgreSQL, le nombre qui figure en position x désigne une version mineure pour PostgreSQL 10.x et versions ultérieures.

  • PostgreSQL 12.4 (64 bits)
    • PostGIS 3.0.1
  • PostgreSQL 11.9 (64 bits)
    • PostGIS 3.0.1
  • PostgreSQL 10.14 (64 bits)
    • PostGIS 3.0.1

Remarque :

En raison de l’évolution de la prise en charge des types de données dans PostgreSQL12.x, si votre base de données contient une géodatabase, vous devez utiliser les commandes pg_dump et pg_restore pour procéder à une mise à niveau vers PostgreSQL12.x. Lorsque vous recourez à cette méthode de mise à niveau, les champs OID non pris en charge et inutilisés sont supprimés des tables système de géodatabase qui vous empêcheraient sinon de procéder à la mise à niveau vers PostgreSQL 12.x.

Une fois la mise à niveau vers PostgreSQL 12.x effectuée, si la base de données contient une géodatabase, ArcGIS 10.8 et les clients antérieurs ainsi que ArcGIS Pro 2.5 et les versions antérieures ne peuvent plus utiliser les données. Vous devez mettre à niveau vos clients ArcGIS.

Esri teste et certifie les installations PostgreSQL disponibles sur PostgreSQL.org. Pour chaque version de PostgreSQL prise en charge par Esri, les modules PostGIS disponibles sont également testés et certifiés. Aucun autre module d’extension de la fonctionnalité PostgreSQL n’est inclus dans la certification Esri.

Systèmes d'exploitation pris en charge

Si vous utilisez une géodatabase dans PostgreSQL ou le type ST_Geometry dans une base de données PostgreSQL, les systèmes d’exploitation suivants ont été testés et correspondent à la version minimale prise en charge. Les mises à jour ou Service Packs futurs de ces versions de systèmes d’exploitation sont pris en charge et censés fonctionner, sauf indication contraire. La version et les mises à jour du système d'exploitation doivent également être prises en charge par le fournisseur du système d'exploitation.

Microsoft Windows

Pour utiliser une géodatabase ou le type ST_Geometry dans PostgreSQL sur Windows, vous devez installer le dernier redistribuable Microsoft Visual C++ pour Visual Studio 2015, 2017 et 2019 sur la machine PostgreSQL. Consultez les derniers téléchargementsVisual C++ pris en charge de Microsoft pour plus d’informations.

Système d'exploitation pris en chargeDernière mise à jour ou dernier Service Pack testés

Windows Server 2019 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2016 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2012 R2 Standard et Datacenter

Mise à jour de février 2021

Windows Server 2012 Standard et Datacenter

Mise à jour de février 2021

Système d'exploitation pris en chargeDernière mise à jour ou dernier Service Pack testés

Windows 10 Professionnel et Entreprise (64 bits [EM64T])

Mise à jour de février 2021

Windows 8,1 Professionnel et Entreprise (64 bits [EM64T])

Mise à jour de février 2021

Remarque :

  • Les mises à jour ou Service Packs antérieurs ou futurs de ces systèmes d’exploitation sont pris en charge, sauf indication contraire. La version et les mises à jour du système d'exploitation doivent également être prises en charge par le fournisseur du système d'exploitation.
  • Windows 10 et 8.1 peuvent uniquement être utilisés pour les tests de base et le développement d’applications. Ils ne sont pas recommandés pour un déploiement dans un environnement de production.

Prise en charge du cloud

Consultez Configuration requise pour utiliser ArcGIS avec des bases de données dans le cloud pour en savoir plus sur le support pour les services de base de données et les bases de données déployés dans le cloud.

Connexions à PostgreSQL

Les applications ArcGIS capables de se connecter à une base de données PostgreSQL contiennent les bibliothèques de client PostgreSQL nécessaires à l’établissement d’une connexion. Il s’agit des applications ArcGIS Server, ArcGIS Pro, ArcGIS Desktop et ArcReader.

Seules sont prises en charge les connexions d’ArcGIS vers PostgreSQL qui sont authentifiées par la base de données.