Skip To Content

Compatibilité client/géodatabase

Vous pouvez accéder aux géodatabases à l'aide de plusieurs logiciels clients ArcGIS. On compte les suivantes :

  • ArcGIS Pro (prise en charge de la connexion aux géodatabases fichier et d’entreprise)
  • services ArcGIS Server (prise en charge de la connexion aux géodatabases fichier, de groupe de travail et d’entreprise)

Versions compatibles

Vous n’êtes pas obligé d’utiliser une géodatabase et des clients ArcGIS présentant une version identique, mais nous le recommandons. Les géodatabases et le logiciel client sont conçus pour fonctionner ensemble et vous risquez de rencontrer des problèmes ou de remarquer un comportement inhabituel en utilisant des versions très différentes.

Cela se vérifie en particulier lorsque vous utilisez plusieurs versions de clients sur votre site. Un client récent peut créer dans la base de données des types de jeux de données récents auxquels les clients plus anciens ne peuvent pas accéder. Pour les géodatabases d’entreprise, si vous laissez passer trop de temps entre les mises à niveau, vous devrez peut-être mettre à niveau la base de données sous-jacente plusieurs fois avant de pouvoir mettre à niveau la géodatabase.

La version de la géodatabase d’une géodatabase d'entreprise est stockée dans une table système. Elle indique la version de client que vous avez utilisée pour créer ou mettre à niveau la géodatabase. Si, par exemple, vous créez une géodatabase d’entreprise depuis ArcMap 10.6.1, la version de géodatabase est 10.6.1. Si, par la suite, vous mettez à niveau la même géodatabase à l’aide de ArcGIS Pro 2.6, la version de la géodatabase est 10.8.1.2.6. Gardez à l’esprit que cette version de la géodatabase est principalement utilisée par le support technique Esri à des fins de dépannage et qu’elle ne présente pas la totalité des fonctions à votre disposition. En effet, de nombreuses fonctions de géodatabase sont implémentées dans les clients qui y accèdent, et non dans la géodatabase elles-même.

Pour les géodatabases d'entreprise, la version de la géodatabase ne reflète essentiellement que la version de logiciel que vous avez utilisée pour créer ou mettre à niveau la géodatabase. La version des géodatabases fichier n’a pas changé depuis la version 10.1.

Les règles de compatibilité suivantes s’appliquent :

  • Utilisez des versions d’ArcGIS prises en charge pour vos clients et la géodatabase.
  • Vous devez stocker votre géodatabase d’entreprise dans une version de base de données prise en charge à la fois pour la géodatabase et la version d’ArcGIS utilisées. Le client de base de données que vous installez sur la machine cliente ArcGIS doit également être compatible avec votre version ArcGIS. Pour plus d’informations sur les versions prises en charge des bases de données et des clients de base de données, reportez-vous aux pages qui suivent. Utilisez la liste déroulante Other versions (Autres versions) pour consulter les informations concernant les anciennes versions logicielles et les autres systèmes d’exploitation.
  • Les clients ArcGIS comportent également l’API pour ce client. Ainsi, les mêmes règles de compatibilité de versions s’appliquent lors de l’accès à la géodatabase à l’aide de l’API.
  • Lorsque vous utilisez des clients qui se connectent à un service ArcGIS Server, comme ArcGIS Collector ou ArcGIS Survey123, ArcGIS Server est en fait le client associé à la géodatabase. Dans ce cas, assurez-vous que les versions du logiciel ArcGIS Server et de la géodatabase sont compatibles.
  • Les clients ArcGIS plus anciens peuvent ouvrir, interroger, modifier et enregistrer des données dans les versions plus récentes des géodatabases. Cependant, ils ne peuvent pas ouvrir les jeux de données qui participent aux nouvelles fonctionnalités. Si vous essayez d’accéder à un type de jeu de données plus récent à partir d’un client ArcGIS plus ancien, vous rencontrerez les messages d'erreur suivants :

    Impossible d’ouvrir le jeu de données, car il n’est pas compatible avec cette version du client de géodatabase.

    Échec de l’ajout des données. Type de données non pris en charge.

  • Pour vous connecter à partir d’un client ArcGIS récent à une géodatabase d’entreprise plus ancienne, appliquez le dernier correctif associé à la version de la géodatabase, s’il existe.
  • Si vous utilisez la réplication de géodatabase, la géodatabase de réplica enfant doit présenter la même version, ou une version ultérieure, que la géodatabase de réplica parent. Pour plus d’informations, reportez-vous à la rubrique Compatibilité entre la réplication et la géodatabase.
  • Vous ne pouvez pas utiliser ArcMap pour accéder aux jeux de données qui participent aux fonctionnalités propres à ArcGIS Pro. Par exemple, vous ne pouvez pas accéder à des jeux de données de branche versionnée, des réseaux techniques ou des jeux de données avec des règles attributaires ArcMap.
  • Si vous mettez à niveau votre géodatabase et utilisez l’outil de géotraitement Upgrade Dataset (Mettre à niveau le jeu de données) pour mettre à niveau des jeux de données spécifiques, vous ne pourrez peut-être pas ouvrir le jeu de données à partir de ArcMap.

Quand mettre à niveau une géodatabase ?

Il est préférable que les versions de la géodatabase et du client soient aussi proches que possible. Il arrive que la géodatabase doive être mise à niveau. Vous devez mettre à niveau votre géodatabase si vous êtes dans l’un des cas suivants :

  • La version cliente que vous utilisez ne peut se connecter à la version de géodatabase que vous souhaitez utiliser. Pour les géodatabases d'entreprise, la version de client que vous utilisez risque de ne pas pouvoir se connecter à la version de système de gestion de bases de données que vous utilisez et vous devez mettre à niveau la base de données et la géodatabase pour vous connecter à partir d’un client plus récent.
  • Vous souhaitez tirer profit des fonctionnalités uniquement disponibles dans une version plus récente de la géodatabase. Consultez chaque version de la rubrique Nouveautés de ArcGIS Pro pour obtenir des informations sur les nouvelles fonctions et les nouveaux types de jeu de données de la géodatabase. Sachez que lorsque vous créez des types de jeu de données, mettez à niveau un jeu de données, tel qu’un atelier parcellaire, ou mettez à niveau un jeu de données réseau, le jeu de données ne sera plus accessible aux clients plus anciens.

Pour plus d'informations sur la mise à niveau des géodatabases, reportez-vous aux rubriques concernant la mise à niveau du type de géodatabase que vous utilisez :

Géodatabases fichier

Mettre à niveau une géodatabase fichier

Géodatabases dans Db2 sur Linux ou Microsoft Windows

Mettre à niveau une géodatabase dans Db2

Géodatabases dans Oracle

Mettre à niveau une géodatabase dans Oracle

Géodatabases dans PostgreSQL

Mettre à niveau une géodatabase dans PostgreSQL

Géodatabases dans SAP HANA

Mettre à niveau une géodatabase dans SAP HANA

Géodatabases d’entreprise dans SQL Server

Mettre à niveau une géodatabase dans SQL Server

Les versions de géodatabase

Parfois, la documentation indique que vous avez besoin d’une version spécifique de la géodatabase pour profiter de certaines fonctionnalités. Souvent, cette version est répertoriée comme étant la version 10.x de la géodatabase. Comme indiqué précédemment, lorsque vous créez ou mettez à niveau une géodatabase d’entreprise dans ArcGIS Pro, le numéro de version de la géodatabase est une combinaison de 10.x et du numéro de version ArcGIS Pro. Lorsque vous créez ou mettez à niveau une géodatabase à partir d’un client 10.x, la version de la géodatabase est uniquement le numéro de version 10.x.

Utilisez les informations de la table suivante pour connaître la version de la géodatabase lorsque vous la créez ou la mettez à niveau depuis ArcGIS Pro.

ArcGIS ProÉquivalent version 10.xVersion de la géodatabase

2.2

10.6.1

10.6.1.2.2

2.3

10.7

10.7.0.2.3

2.4

10.7.1

10.7.1.2.4

2,5

10.8

10.8.0.2.5

2.6

10.8.1

10.8.1.2.6

2.7

10.9

10.9.0.2.7

2.8

10.9

10.9.0.2.8

2.9

10.9.1

10.9.1.2.9